Project

General

Profile

Bug #10606

Ошибка при генерации отчета Table view после включение настройки Sequential Identifiers

Added by Viktoria Kopach 3 months ago. Updated 2 months ago.

Status:
Verified
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/30/2020
Due date:
% Done:

100%

Estimated time:
Detected in build:
1.2.638
Platform:
Windows x64
Published in build:
1.3.642

Description

freemarker.core._TemplateModelException: Java method "static com.unitesk.requality.report.ReportUtils.getDefToUseNodes(com.unitesk.requality.core.TreeNode, String)" threw an exception; see cause exception in the Java stack trace. ---- FTL stack trace ("~" means nesting-related): - Failed at: #local nodes = utils.getDefToUseNodes... [in template "tableview/tv.ftl" in macro "showreq" at line 294, column 57] - Reached through: @showreq child, lvl + 1, path + i [in template "tableview/tv.ftl" in macro "showreq" at line 373, column 33] - Reached through: @showreq child, lvl + 1, path + i [in template "tableview/tv.ftl" in macro "showreq" at line 373, column 33] - Reached through: @showreq child, lvl + 1, path + i [in template "tableview/tv.ftl" in macro "showreq" at line 373, column 33] - Reached through: @showreq rootReq, 0, "" [in template "tableview/tv.ftl" at line 578, column 1] ---- FreeMarker template error: Java method "static com.unitesk.requality.report.ReportUtils.getDefToUseNodes(com.unitesk.requality.core.TreeNode, String)" threw an exception; see cause exception in the Java stack trace. ---- FTL stack trace ("~" means nesting-related): - Failed at: #local nodes = utils.getDefToUseNodes... [in template "tableview/tv.ftl" in macro "showreq" at line 294, column 57] - Reached through: @showreq child, lvl + 1, path + i [in template "tableview/tv.ftl" in macro "showreq" at line 373, column 33] - Reached through: @showreq child, lvl + 1, path + i [in template "tableview/tv.ftl" in macro "showreq" at line 373, column 33] - Reached through: @showreq child, lvl + 1, path + i [in template "tableview/tv.ftl" in macro "showreq" at line 373, column 33] - Reached through: @showreq rootReq, 0, "" [in template "tableview/tv.ftl" at line 578, column 1] ---- Java stack trace (for programmers): ---- freemarker.core._TemplateModelException: [... Exception message was already printed; see it above ...] at freemarker.ext.beans._MethodUtil.newInvocationTemplateModelException(_MethodUtil.java:289) at freemarker.ext.beans._MethodUtil.newInvocationTemplateModelException(_MethodUtil.java:252) at freemarker.ext.beans.SimpleMethodModel.exec(SimpleMethodModel.java:77) at freemarker.core.MethodCall._eval(MethodCall.java:65) at freemarker.core.Expression.eval(Expression.java:83) at freemarker.core.Assignment.accept(Assignment.java:134) at freemarker.core.Environment.visit(Environment.java:366) at freemarker.core.IteratorBlock$IterationContext.executedNestedContentForCollOrSeqListing(IteratorBlock.java:317) at freemarker.core.IteratorBlock$IterationContext.executeNestedContent(IteratorBlock.java:271) at freemarker.core.IteratorBlock$IterationContext.accept(IteratorBlock.java:242) at freemarker.core.Environment.visitIteratorBlock(Environment.java:642) at freemarker.core.IteratorBlock.acceptWithResult(IteratorBlock.java:107) at freemarker.core.IteratorBlock.accept(IteratorBlock.java:93) at freemarker.core.Environment.visit(Environment.java:330) at freemarker.core.Environment.visit(Environment.java:336) at freemarker.core.Environment.visit(Environment.java:336) at freemarker.core.Environment.visit(Environment.java:336) at freemarker.core.Environment.visit(Environment.java:372) at freemarker.core.Environment.invoke(Environment.java:775) at freemarker.core.UnifiedCall.accept(UnifiedCall.java:83) at freemarker.core.Environment.visit(Environment.java:366) at freemarker.core.IteratorBlock$IterationContext.executedNestedContentForCollOrSeqListing(IteratorBlock.java:317) at freemarker.core.IteratorBlock$IterationContext.executeNestedContent(IteratorBlock.java:271) at freemarker.core.IteratorBlock$IterationContext.accept(IteratorBlock.java:242) at freemarker.core.Environment.visitIteratorBlock(Environment.java:642) at freemarker.core.IteratorBlock.acceptWithResult(IteratorBlock.java:107) at freemarker.core.IteratorBlock.accept(IteratorBlock.java:93) at freemarker.core.Environment.visit(Environment.java:330) at freemarker.core.Environment.visit(Environment.java:336) at freemarker.core.Environment.visit(Environment.java:372) at freemarker.core.Environment.invoke(Environment.java:775) at freemarker.core.UnifiedCall.accept(UnifiedCall.java:83) at freemarker.core.Environment.visit(Environment.java:366) at freemarker.core.IteratorBlock$IterationContext.executedNestedContentForCollOrSeqListing(IteratorBlock.java:317) at freemarker.core.IteratorBlock$IterationContext.executeNestedContent(IteratorBlock.java:271) at freemarker.core.IteratorBlock$IterationContext.accept(IteratorBlock.java:242) at freemarker.core.Environment.visitIteratorBlock(Environment.java:642) at freemarker.core.IteratorBlock.acceptWithResult(IteratorBlock.java:107) at freemarker.core.IteratorBlock.accept(IteratorBlock.java:93) at freemarker.core.Environment.visit(Environment.java:330) at freemarker.core.Environment.visit(Environment.java:336) at freemarker.core.Environment.visit(Environment.java:372) at freemarker.core.Environment.invoke(Environment.java:775) at freemarker.core.UnifiedCall.accept(UnifiedCall.java:83) at freemarker.core.Environment.visit(Environment.java:366) at freemarker.core.IteratorBlock$IterationContext.executedNestedContentForCollOrSeqListing(IteratorBlock.java:317) at freemarker.core.IteratorBlock$IterationContext.executeNestedContent(IteratorBlock.java:271) at freemarker.core.IteratorBlock$IterationContext.accept(IteratorBlock.java:242) at freemarker.core.Environment.visitIteratorBlock(Environment.java:642) at freemarker.core.IteratorBlock.acceptWithResult(IteratorBlock.java:107) at freemarker.core.IteratorBlock.accept(IteratorBlock.java:93) at freemarker.core.Environment.visit(Environment.java:330) at freemarker.core.Environment.visit(Environment.java:336) at freemarker.core.Environment.visit(Environment.java:372) at freemarker.core.Environment.invoke(Environment.java:775) at freemarker.core.UnifiedCall.accept(UnifiedCall.java:83) at freemarker.core.Environment.visit(Environment.java:330) at freemarker.core.Environment.visit(Environment.java:336) at freemarker.core.Environment.process(Environment.java:309) at freemarker.template.Template.process(Template.java:384) at com.unitesk.requality.report.ReportGenerator.generateReport(ReportGenerator.java:169) at com.unitesk.requality.report.ReportGenerator.generateReport(ReportGenerator.java:250) at com.unitesk.requality.core.operations.GenerateReportHandler.generateReport(GenerateReportHandler.java:306) at com.unitesk.requality.core.operations.GenerateReportHandler.generateReport(GenerateReportHandler.java:119) at com.unitesk.requality.core.operations.GenerateReportHandler.execute(GenerateReportHandler.java:97) at com.unitesk.requality.eclipse.handlers.report.GenerateReportHandler$3.runInWorkspace(GenerateReportHandler.java:143) at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:39) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55) Caused by: java.lang.NumberFormatException: For input string: "ggggg4332" at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65) at java.lang.Integer.parseInt(Integer.java:580) at java.lang.Integer.parseInt(Integer.java:615) at com.unitesk.requality.report.ReportUtils$1.compare(ReportUtils.java:348) at com.unitesk.requality.report.ReportUtils$1.compare(ReportUtils.java:342) at java.util.TimSort.countRunAndMakeAscending(TimSort.java:355) at java.util.TimSort.sort(TimSort.java:220) at java.util.Arrays.sort(Arrays.java:1438) at com.unitesk.requality.report.ReportUtils.fidSort(ReportUtils.java:342) at com.unitesk.requality.report.ReportUtils.getDefToUseNodes(ReportUtils.java:338) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at freemarker.ext.beans.BeansWrapper.invokeMethod(BeansWrapper.java:1505) at freemarker.ext.beans.SimpleMethodModel.exec(SimpleMethodModel.java:72) ... 65 more

Files

SequentialIdentifiersTableView.docx (13.8 KB) SequentialIdentifiersTableView.docx Viktoria Kopach, 11/30/2020 02:08 PM

History

#1

Updated by Alexey Khoroshilov 3 months ago

  • Target version set to 1.3 (development)
#2

Updated by Denis Kildishev 2 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved
#3

Updated by Denis Kildishev 2 months ago

  • Published in build set to 1.3.642
#4

Updated by Viktoria Kopach 2 months ago

  • Status changed from Resolved to Verified

Also available in: Atom PDF