Project

General

Profile

Feature #10561

Klever Python package is not updated when updating Klever instances locally

Added by Evgeny Novikov 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Urgent
Category:
Documentation
Target version:
Start date:
11/06/2020
Due date:
% Done:

0%

Estimated time:
Published in build:

Description

After recent refactoring of deployment scripts the Klever package is not updated when updating Klever instances locally. Scripts deploy new configurations/specifications, but software remains the same as after installation. One can try to mitigate the issue by using option "-e" during initial installation of the Klever package, but it is not reliable. The issue does not exist for OpenStack Klever instances.

History

#1

Updated by Ilya Shchepetkov 2 months ago

Klever Python package must be installed manually before local deployment, and also must be updated manually and separately, as noted in the Documentation. Local deployment scripts are part of the Klever Python package, and it is really not a very good idea for package code to try to update itself. These scripts also do not know how the Klever Python package was installed (with or without -e option, for example), so they can mess everything up when trying to update it.

So, this is not a bug, but a design decision. I am not yet sure that we should try to change it.

#2

Updated by Evgeny Novikov 2 months ago

  • Category changed from Deployment to Documentation

Thank you for the detailed explanation. I suggest to explicitly and noticeably mention about necessity to update the Klever Python package at the corresponding place within the documentation, that is here, since people including even Klever developers forgot notes provided at the parent page.

#3

Updated by Evgeny Novikov about 2 months ago

  • Detected in build deleted (git)
  • Priority changed from Immediate to Urgent
  • Tracker changed from Bug to Feature
#4

Updated by Ilya Shchepetkov about 2 months ago

  • Status changed from New to Resolved

Some clarifications to documentation were added in feature-10561 branch.

#5

Updated by Evgeny Novikov about 2 months ago

  • Status changed from Resolved to Closed

After small improvements I merged the branch to master in b07aee9d1. Let's hope that users including me will not forget to update Klever Python package anymore.

Also available in: Atom PDF