Project

General

Profile

Bug #10468

Improve environment models for runtime power management callbacks

Added by Ilja Zakharov 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Environment model
Target version:
Start date:
08/19/2020
Due date:
% Done:

0%

Estimated time:
Detected in build:
git
Platform:
Published in build:

Description

There is a PM specification for general PM callbacks that are available for implementation in several kinds of bus drivers. The latest runs show that there are many false alarms caused by an incorrect order of invocation of runtime callbacks. One needs to investigate reasons and improve existing specifications.

Examples (clk2)
drivers/media/platform/stm32/stm32-dcmi.ko
drivers/media/platform/sti/delta/st-delta.ko
drivers/media/platform/qcom/venus/venus-enc.ko
drivers/media/platform/rockchip/rga/rockchip-rga.ko
drivers/media/platform/sunxi/sun4i-csi/sun4i-csi.ko
drivers/media/platform/sunxi/sun8i-di/sun8i-di.ko
drivers/media/platform/mtk-jpeg/mtk_jpeg.ko
drivers/media/platform/s5p-cec/s5p-cec.ko

History

#1

Updated by Ilja Zakharov 5 months ago

  • Status changed from New to Feedback

Implemented in runtime-pm-fixes.

Note, that some FP are not gone because of rule-related problems.

#2

Updated by Evgeny Novikov 5 months ago

  • Status changed from Feedback to Resolved

Ilja fixed the model one more time, so, it seems, that now everything is okay, but let's wait for new testing results.

#3

Updated by Evgeny Novikov 5 months ago

  • Status changed from Resolved to Closed
  • Subject changed from Improve environment models for runtime power management callbacks. to Improve environment models for runtime power management callbacks

Tested passed. Moreover, CI showed that 2 negative regressions introduced by branch extra-specifications have gone. Testing on real-world drivers demonstrate that corresponding false alarms disappear, but the environment model became a slightly more complicated, so, there are several new timeouts. So, I merged the branch to master in 30baa063e.

Also available in: Atom PDF