Project

General

Profile

Feature #10460

Get rid of unclear parentheses when representing Safes, Unsafes and Unknowns

Added by Evgeny Novikov 5 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Urgent
Category:
Bridge
Target version:
Start date:
08/11/2020
Due date:
08/26/2020
% Done:

90%

Estimated time:
Published in build:

Description

At the moment Bridge represents Safes, Unsafes and Unknowns using a too short and unclear to the most of users form. Let's get rid of parentheses and represent leaf reports using some appropriate words.

For Unsafes we expect to have:
  • Unsafes: the total number of Unsafes
  • Bugs: the total number of Unsafes associated somehow with marks having the total verdict "Bug"
    • Confirmed: the total number of Bugs that are either assessed manually or which automatic associations were confirmed by hand.
    • Unconfirmed: the total number of remaining Bugs
  • False positives: like for Bugs
  • To be assessed: the total number of Unsafes that have not any associated marks

Ditto for Safes.

For Unknowns I just would like to replace "(N)" with ": N".


Related issues

Blocks Klever - Feature #10465: Update Klever tutorialClosed08/17/2020

Actions
Blocks Klever - Bug #10490: Fix messages and their translationClosed09/08/2020

Actions

History

#1

Updated by Ilya Shchepetkov 5 months ago

Just want to say that the current system of representing verdicts is completely incomprehensible for me. I would love to see some changes here!

#2

Updated by Evgeny Novikov 5 months ago

In addition, I would like to make similar changes within tables representing Unsafes, Safes and Unknowns, i.e. to split column "Number of associated marks" into 2 columns: "Confirmed" and "Automatic". I guess that the total number of associated marks for a particular leaf report is out of interest (everybody can sum two small numbers quickly if necessary), so we can omit it completely.

#3

Updated by Evgeny Novikov 5 months ago

#4

Updated by Vladimir Gratinskiy 5 months ago

  • % Done changed from 0 to 90
  • Status changed from New to Feedback
  • Due date set to 08/26/2020

Implemented in branch "bridge_10460".

#5

Updated by Evgeny Novikov 5 months ago

My notes and suggestions:
  1. Do not show zero length categories like "Manually assessed: 0". There is "Automatically assessed: 1" at once in addition.
  2. I can not unconfirm confirmed associations.
  3. Associations with unknown marks seems to be broken. I see one mark under section "Dissimilar marks" though its pattern exactly corresponds to unknown error message. Ditto for safes and their marks. For safes/unknowns similarity does not have sense due to they have much more simple rules of mark association in comparison with unsafes.
  4. I do not see a new column "Total status" on the unsafe list page. Besides total status "Incompatible marks" looks strange. Let's name it "Incompatible statuses".
  5. When I specified tags for dissimilar mark, I saw changes in total status "Unreported -> Reported".
#6

Updated by Evgeny Novikov 5 months ago

  • Status changed from Feedback to Open
#7

Updated by Evgeny Novikov 5 months ago

Evgeny Novikov wrote:

My notes and suggestions:
  1. I do not see a new column "Total status" on the unsafe list page. Besides total status "Incompatible marks" looks strange. Let's name it "Incompatible statuses".

Sorry, I misinterpreted wording regarding "Incompatible marks", so, this is not an issue.

#8

Updated by Vladimir Gratinskiy 5 months ago

  • Status changed from Open to Feedback

Evgeny Novikov wrote:

My notes and suggestions:
  1. Do not show zero length categories like "Manually assessed: 0". There is "Automatically assessed: 1" at once in addition.

Fixed.

  1. I can not unconfirm confirmed associations.

Fixed.

  1. Associations with unknown marks seems to be broken. I see one mark under section "Dissimilar marks" though its pattern exactly corresponds to unknown error message. Ditto for safes and their marks. For safes/unknowns similarity does not have sense due to they have much more simple rules of mark association in comparison with unsafes.

There was a bug when celery task for associating unknown and safes set default Dissimilar association type. The bug was fixed.

  1. I do not see a new column "Total status" on the unsafe list page. Besides total status "Incompatible marks" looks strange. Let's name it "Incompatible statuses".

Total status was added on the unsafes list page.

  1. When I specified tags for dissimilar mark, I saw changes in total status "Unreported -> Reported".

I guess this problem was because of celery task bug, but did not check it.

#9

Updated by Evgeny Novikov 5 months ago

  • Status changed from Feedback to Open
Updated notes and comments:
  1. There is no sense to use word "similar" or something like that for safes and unknowns. However, this is the case within tables with safes/unknowns and on particular safe/unknown pages.
  2. I still see "Without marks" for unknowns even though there are some associations under "Similar marks with automatic associations".
  3. I would suggest to make similar "refactoring" for tables of marks as well as for individual marks. For instance, instead of "Number of associated leaf reports" it would be better to see "Similar unsafe associations" (or "Safe/unknown associations) with two subcolumns "Confirmed" and "Automatic". On a mark page it has sense to demonstrate almost the same table as on a page of a report of a corresponding type. At the moment there is still unclear flag "Is associated" and so on.
#10

Updated by Evgeny Novikov 5 months ago

  • Status changed from Open to Resolved

From my point of view everything looks great now. I postpone merge to master since this branch breaks backward compatibility.

#11

Updated by Evgeny Novikov 5 months ago

  • Blocks Bug #10490: Fix messages and their translation added
#12

Updated by Evgeny Novikov 2 months ago

  • Status changed from Resolved to Closed

I merged this branch to master in f4710685d. Note, that this change is not backward compatible, so, you need to completely reinstall Klever. But the change clarifies and accomplishes statistics in such the way that you will not complain after update.

Also available in: Atom PDF