Project

General

Profile

Bug #10415

GIT: При переключении на другую версию возникает окно с сообщением об ошибке

Added by Viktoria Kopach 14 days ago. Updated 6 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/29/2020
Due date:
% Done:

100%

Estimated time:
Detected in build:
1.2.607
Platform:
Windows x64
Published in build:

Description

При переключении на другую версию возникает окно с сообщением об ошибке. Возникало и при переключении на более раннюю версию, и при переключении обратно на branch.

Текст ошибки из Error log:

eclipse.buildId=4.6.3.M20170301-0400
java.version=1.8.0_242
java.vendor=AdoptOpenJDK
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Framework arguments:  -product com.unitesk.requality.product.product -perspective com.unitesk.requality.main.perspective -perspective com.unitesk.requality.main.perspective -product com.unitesk.requality.product.product -perspective com.unitesk.requality.main.perspective -perspective com.unitesk.requality.main.perspective
Command-line arguments:  -os win32 -ws win32 -arch x86 -product com.unitesk.requality.product.product -perspective com.unitesk.requality.main.perspective -perspective com.unitesk.requality.main.perspective -data D:\Work\Eclipse Workspaces\workspace1 -product com.unitesk.requality.product.product -perspective com.unitesk.requality.main.perspective -perspective com.unitesk.requality.main.perspective

org.eclipse.e4.ui.workbench
Error
Mon Jun 29 19:12:12 MSK 2020
ERROR:org.eclipse.swt.SWTException: Widget is disposed
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.SWT.error(SWT.java:4419)
    at org.eclipse.swt.widgets.Widget.error(Widget.java:482)
    at org.eclipse.swt.widgets.Widget.getDisplay(Widget.java:596)
    at com.unitesk.requality_git.eclipse.NodeVersionsComposite$1.open(NodeVersionsComposite.java:108)
    at com.unitesk.requality.core.storage.TrackerNotifier.notifyListeners(TrackerNotifier.java:25)
    at com.unitesk.requality.eclipse.core.EclipseTracker.notifyListeners(EclipseTracker.java:173)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:892)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:525)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:345)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackTreeDB(EclipseTracker.java:1137)
    at com.unitesk.requality.core.api.Global.clearCachesAndReopen(Global.java:61)
    at com.unitesk.requality_git.comm.GitSwitchToOld.call(GitSwitchToOld.java:183)
    at com.unitesk.requality_git.comm.GitSwitchToOld.call(GitSwitchToOld.java:156)
    at com.unitesk.requality_git.comm.GitSwitchToOld$2.run(GitSwitchToOld.java:79)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

java.lang.RuntimeException: org.eclipse.swt.SWTException: Widget is disposed
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.SWT.error(SWT.java:4419)
    at org.eclipse.swt.widgets.Widget.error(Widget.java:482)
    at org.eclipse.swt.widgets.Widget.getDisplay(Widget.java:596)
    at com.unitesk.requality_git.eclipse.NodeVersionsComposite$1.open(NodeVersionsComposite.java:108)
    at com.unitesk.requality.core.storage.TrackerNotifier.notifyListeners(TrackerNotifier.java:25)
    at com.unitesk.requality.eclipse.core.EclipseTracker.notifyListeners(EclipseTracker.java:173)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:892)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:525)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:345)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackTreeDB(EclipseTracker.java:1137)
    at com.unitesk.requality.core.api.Global.clearCachesAndReopen(Global.java:61)
    at com.unitesk.requality_git.comm.GitSwitchToOld.call(GitSwitchToOld.java:183)
    at com.unitesk.requality_git.comm.GitSwitchToOld.call(GitSwitchToOld.java:156)
    at com.unitesk.requality_git.comm.GitSwitchToOld$2.run(GitSwitchToOld.java:79)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:540)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackProject(EclipseTracker.java:345)
    at com.unitesk.requality.eclipse.core.EclipseTracker.trackTreeDB(EclipseTracker.java:1137)
    at com.unitesk.requality.core.api.Global.clearCachesAndReopen(Global.java:61)
    at com.unitesk.requality_git.comm.GitSwitchToOld.call(GitSwitchToOld.java:183)
    at com.unitesk.requality_git.comm.GitSwitchToOld.call(GitSwitchToOld.java:156)
    at com.unitesk.requality_git.comm.GitSwitchToOld$2.run(GitSwitchToOld.java:79)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


Files

19_06.png (128 KB) 19_06.png Viktoria Kopach, 06/29/2020 07:15 PM

History

#1

Updated by Alexey Khoroshilov 14 days ago

  • Target version set to 1.2 (beta)
#2

Updated by Denis Kildishev 14 days ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved
#3

Updated by Denis Kildishev 9 days ago

  • Published in build set to 1.2.610
#4

Updated by Viktoria Kopach 7 days ago

Сейчас окно с ошибкой не возникает, но в Error log:

eclipse.buildId=4.6.3.M20170301-0400
java.version=1.8.0_242
java.vendor=AdoptOpenJDK
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ru_RU
Framework arguments:  -product com.unitesk.requality.product.product -perspective com.unitesk.requality.main.perspective -perspective com.unitesk.requality.main.perspective
Command-line arguments:  -os win32 -ws win32 -arch x86 -product com.unitesk.requality.product.product -perspective com.unitesk.requality.main.perspective -perspective com.unitesk.requality.main.perspective

org.eclipse.ui
Error
Mon Jul 06 17:44:32 MSK 2020
Unhandled event loop exception

org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.swt.SWTException: Widget is disposed)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.eclipse.swt.SWTException: Widget is disposed
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.SWT.error(SWT.java:4419)
    at org.eclipse.swt.widgets.Widget.error(Widget.java:482)
    at org.eclipse.swt.widgets.Widget.getDisplay(Widget.java:596)
    at com.unitesk.requality_git.eclipse.NodeVersionsComposite$1$1.run(NodeVersionsComposite.java:112)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 23 more

#5

Updated by Viktoria Kopach 7 days ago

  • Status changed from Resolved to Open
#6

Updated by Denis Kildishev 6 days ago

  • Status changed from Open to Resolved
#7

Updated by Viktoria Kopach 6 days ago

  • Published in build deleted (1.2.610)

Also available in: Atom PDF