Project

General

Profile

Bug #10181

CacheUnitTestCase causes StackOverflowError

Added by Alexander Kamkin 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
High
Category:
MMU Plugin
Target version:
Start date:
03/24/2020
Due date:
% Done:

0%

Estimated time:
Detected in build:
git
Platform:
Published in build:

Description

ru.ispras.microtesk.mmu.model.sim.CacheUnitTestCase > test FAILED
    java.lang.StackOverflowError

History

#1

Updated by Alexander Kamkin 7 months ago

  • Priority changed from Normal to High
#2

Updated by Alexander Kamkin 7 months ago

  • Status changed from New to Resolved

The problem is as follows:

  • L2.evictEntry()
    • L2.sendSnoopEvict()
      • L1.evictEntry() (invalidate back)
        • L1.sendSnoopEvict()
          • L2.writeEntry() (write back)
            • redundant snoops causing infinite looping

Also available in: Atom PDF