Project

General

Profile

Bug #10160

Bridge does not apply some unknown marks

Added by Ilja Zakharov 2 months ago. Updated 2 months ago.

Status:
Rejected
Priority:
Immediate
Assignee:
-
Category:
Bridge
Target version:
Start date:
03/13/2020
Due date:
% Done:

0%

Estimated time:
Detected in build:
git
Platform:
Published in build:

Description

I have two different runs made using different Klever versions but with the same Bridge. I have several unknown reports in the latest run for which Bridge does not apply an existing mark. Even when I create a new job and run it I still get the report uncovered by the mark but it should be covered and was covered previously. Logs are the same and the mark ("There is no module initialization function provided") has not been changed. However, Bridge still applies the mark to about 1/3 of all corresponding unknown reports, so this functionality is not completely broken.

There are two reports below with the same attributes. But one of them has a mark and the second one has not.

There is no mark!


Files

img3.png (81.2 KB) img3.png Ilja Zakharov, 03/13/2020 12:28 PM
img2.png (86.1 KB) img2.png Ilja Zakharov, 03/13/2020 12:30 PM

History

#1

Updated by Evgeny Novikov 2 months ago

  • Priority changed from Urgent to Immediate

This is a crucial regression.

#2

Updated by Vladimir Gratinskiy 2 months ago

It seems like the celery task for assoicating unknown marks is not finished yet or failed. Please attach logs for the failed task from "/admin/django_celery_results/taskresult/" if any or wait until such tasks are finished.

#3

Updated by Ilja Zakharov 2 months ago

  • Status changed from New to Resolved

The problem was related to celery package version.

But there were some other fixes implemented in bridge-fixes.

#4

Updated by Evgeny Novikov 2 months ago

  • Assignee deleted (Vladimir Gratinskiy)
  • Status changed from Resolved to Rejected

I guess that other fixes are not relevant for the given issue.

Also available in: Atom PDF