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Глава 1

Теория типов?
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Дисклеймеры

По содержанию
▶ Область, о которой речь, развивается с большой скоростью
▶ Целью доклада не ставится

� глубинное и исчерпывающее изложение
� изложение теории

▶ Цель доклада
� показать как вообще бывает, если вы с таким не сталкивались
� показать как ещё бывает, если вы с чем-то таким сталкивались

По оформлению
▶ Будет очень много кода
▶ Плавно появляющийся материал и оверлеи
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Контекст

Типизированные языки программирования

▶ Типы как выразительное средство
▶ Типы как помощь для правильной реализации

QTT — именно теория, не относится к конкретному языку
▶ На ней и её вариациях уже построено несколько языков

� Idris, Granule, Juvix, Gerty

▶ Не обязательно с зависимыми типами
▶ Не обязательно функциональные
▶ Частный случай: линейные типы

� Rust, Linear Haskell, Cogent, …
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Стечения обстоятельств рассмотрения (волюнтаризмы)

Язык для демонстраций
▶ чисто функциональный

▶ с зависимыми типами
▶ синтаксис Idris 2 с вольными расширениями

Параметризация QTT
▶ в самом Idris 2 частный случай
▶ будут примеры более общей параметризации
▶ эти общие примеры могут не компилироваться

Специфичные для QTT аннотации в коде могут принадлежать
▶ стрелке функций (a -> b vs. a -o b или a %1-> b)
▶ аргументам функций и полям структур данных
▶ типу
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Центральная мысль

Точные (в частности, зависимые) типы — о том, что можно

head : (l : List a) -> NonEmpty l => a
index : Fin len -> Vect len a -> a
(++) : Vect n a -> Vect m a -> Vect (n + m) a
interface Eq a where

(==) : a -> a -> Bool
eqRefl : (x : a) -> So (x == x)
eqSymm : (x, y : a) -> x == y = y == x
eqTrans : (x, y, z : a) -> So (x==y) -> So (y==z) -> So (x==z)

QTT — о том, когда можно
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Глава 2

«Ноль»
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Ограничения на параметры

%default total

head : (l : List a) -> NonEmpty l => a

head (x::_) = x
head : (l : List a) -> {auto _ : NonEmpty l} -> a
head (x::_) = x
head : (l : List a) -> {auto 0 _ : NonEmpty l} -> a
head (x::_) = x
head : (l : List a) -> (0 _ : NonEmpty l) => a
head (x::_) = x

0-параметры
▶ можем рассуждать о них при компиляции
▶ не можем использовать при выполнении
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head (x::_) = x
head : (l : List a) -> {auto 0 _ : NonEmpty l} -> a
head (x::_) = x
head : (l : List a) -> (0 _ : NonEmpty l) => a
head (x::_) = x

0-параметры
▶ можем рассуждать о них при компиляции
▶ не можем использовать при выполнении
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Явные “мета”-параметры

interface Monad m => MonadState stateType m | m where
get : m stateType
put : stateType -> m Unit

f : (MonadState Int m, MonadState Nat m, Monad m) => m Integer
f = put {- Int -} 0 *> map natToInteger get

the : (a : Type) -> (x : a) -> a
the _ x = x
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Proof-carrying code

filt : (p : a -> Bool) -> List a -> List (x : a ** p x = True)

record DPair a p where
constructor MkDPair
fst : a
snd : p fst

filt : (p : a -> Bool) -> List a -> List $ Subset a (\x=>p x = True)
filt p [] = []
filt p (x::xs) = case @@ p x of

(True ** prf) => Element x prf :: filt p xs
(False ** _) => filt p xs
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Parametricity

id : a -> a
id x = x

▶ Гордость Haskell’я: подобная сигнатура допускает единственную
реализацию

id : forall a. a -> a
id x = x
id : {a : Type} -> a -> a
id x = x

id : {0 a : Type} -> a -> a
id x = x

▶ На самом деле forall a — сахар для {0 a : _}
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Parametricity важно, что нет в runtime
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Когда ещё важно

data Nat = Z | S Nat
Удобно рассуждать
Неэкономно в рантайме *

data BNat : Nat -> Type where
BZ : BNat 0
B0 : BNat n -> BNat (2*n)
B1 : BNat n -> BNat (1 + 2*n)

(+) : BNat n -> BNat m -> BNat (n + m)

toNat : BNat n -> Subset Nat (\k => k = n)
toNat x = Element n Refl
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(+) : BNat n -> BNat m -> BNat (n + m)

toNat : BNat n -> Subset Nat (\k => k = n)
toNat BZ = Element 0 Refl
toNat (B0 x) = let Element s prf = toNat x in

Element (2*s) rewrite prf in Refl
toNat (B1 x) = let Element s prf = toNat x in
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Нет в runtime — не значит нельзя матчить

record Subset a p where -- напоминание --
constructor Element
fst : a
0 snd : p fst

data All : (0 p : a -> Type) -> List a -> Type where
Nil : All p Nil
(::) : {0 xs : List a} -> p x -> All p xs -> All p (x::xs)

pushIn : (xs : List a) -> (0 _ : All p xs) -> List $ Subset a p
pushIn [] _ = []
pushIn (x::xs) prf = ?pushIn_rhs
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pushIn : (xs : List a) -> (0 _ : All p xs) -> List $ Subset a p
pushIn [] _ = []
pushIn (x::xs) prf = ?pushIn_rhs
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Когда?

0
▶ никогда в рантайме
▶ неограниченно для рассуждений при компиляции

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 14 /61



Когда?

0
▶ никогда

в рантайме
▶ неограниченно для рассуждений при компиляции

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 14 /61



Когда?

0
▶ никогда в рантайме
▶ неограниченно для рассуждений при компиляции

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 14 /61



Глава 3

«Один»
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Данные vs. ресурсы

Компиляторы редко оперируют понятием ресурса

Данные обычно
▶ неограниченно долго (много) используемые
▶ неограниченно много копируемые
▶ можно выбросить в любой момент

Реальный мир так не устроен

Данными мы иногда моделируем вещи реального мира

Это всё порой приводит к проблемам
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Нельзя несколько

Вспомните итераторы из любимых вами языков

Нельзя несколько раз удалить файл

Искусственный пример

data DisResult = CantDisconnect | Disconnected
data DisconnectGrant : Arm -> Type where ...
wantDisconnect : (arm : Arm) -> IO $ Maybe $ DisconnectGrant arm
disconnect : DisconnectGrant arm -> IO Unit
whatever : IO DisResult
whatever = do

Just rm <- wantDisconnect LeftTopArm
| Nothing => pure CantDisconnect

disconnect rm
pure Disconnected
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Нельзя выкидывать

Пример: специальное обязательство для закрытия файла

data ClosingLia : File -> Type where ...

openFile : (fl : File) -> IO $ Maybe $ ClosingLia fl
readChar : (fl : File) -> (0 _ : ClosingLia fl) => IO Char
closeFile : ClosingLia h -> IO Unit
whatever : File -> IO $ Either String Char
whatever fl = do

Just cl <- openFile fl
| Nothing => pure $ Left "Can't open"

c <- readChar fl
closeFile cl
pure $ Right c
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Линейные типы

Линейный параметр
▶ используется в рантайме строго один раз

� нельзя копировать
� нельзя не использовать

▶ …если функция используется строго один раз

“Использовать”
▶ pattern match
▶ вернуть
▶ передать в функцию как параметр с ненулевым quantity
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Возможности линейных типов

Отражать в сигнатурах больше
Отражать в сигнатурах новое

▶ Ресурсы
▶ Протоколы

Оптимизация выполнения
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Более точные спецификации функций

data List : Type -> Type where
Nil : List a
(::) : (1 _ : a) -> (1 _ : List a) -> List a

(++) : List a -> List a -> List a
[] ++ ys = ?concat_rhs1
(x::xs) ++ ys = ?concat_rhs2

 

0 a : Type
1 ys : List a
------------------------------
concat_rhs1 : List a
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Более точные спецификации функций

data List : Type -> Type where
Nil : List a
(::) : (1 _ : a) -> (1 _ : List a) -> List a

(++) : (1 _ : List a) -> (1 _ : List a) -> List a
[] ++ ys = ys
(x::xs) ++ ys = ?concat_rhs2

0 a : Type
1 x : a
1 xs : List a
1 ys : List a
------------------------------
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Более точные спецификации функций

data List : Type -> Type where
Nil : List a
(::) : (1 _ : a) -> (1 _ : List a) -> List a

(++) : (1 _ : List a) -> (1 _ : List a) -> List a
[] ++ ys = ys
(x::xs) ++ ys = x :: xs ++ ys

0 a : Type
1 x : a
1 xs : List a
1 ys : List a
------------------------------
concat_rhs2 : List a
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Не все данные одинаково полезны

data List : Type -> Type where
Nil : List a
(::) : (1 _ : a) -> (1 _ : List a) -> List a

null : (1 _ : List a) -> Bool

null [] = True
null (_::_) = False

Фантазии:
▶ данные, полиморорфные по quantity
▶ промежуточная quantity, только на pattern matching: 0 < pm < 1

А что, например, с
▶ head : (l : List a) -> (0 _ : NonEmpty l) => a
▶ tail : (l : List a) -> (0 _ : NonEmpty l) => a
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Фантазируем дальше: очень точные спецификации

data List : Type -> Type where
Nil : List a
(::) : (? x : a) -> (? xs : List a) -> List a

(++) : (1 _ : List a) -> (1 _ : List a) -> List a
null : (pm _ : List a) -> Bool

head : (1{x=1,xs=0} l : List a) -> (0 _ : NonEmpty l) => a
tail : (1{x=0,xs=1} l : List a) -> (0 _ : NonEmpty l) => a

Философский вопрос: нужно ли это?
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Псевдо-quantity-полифорфизм
data LinOrW = Linear | W
data List' : {l, r : LinOrW} -> Type -> Type where

Nil : List' a
(::) : a -> List' a -> List' {l=W,r=W} a

(.::) : (1 _ : a) -> List' a -> List' {l=1,r=W} a
(::.) : a -> (1 _ : List' a) -> List' {l=W,r=1} a
(.::.) : (1 _ : a) -> (1 _ : List' a) -> List' {l=1,r=1} a

relax : (1 _ : List' a) -> List' {l=1,r=1} a

null : (1 _ : List' {l=W,r=W} a) -> Bool
(++) : (1 _ : List' {l=1,r=1} a) -> (1 _ : List' {l=1,r=1} a) ->

List' {l=1,r=1} a

f : List' a -> List' a -> List' {l=1,r=1} a
f xs ys = relax xs ++ relax ys
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Напоминание: возможности линейных типов

Отражать в сигнатурах больше
Отражать в сигнатурах новое

▶ Ресурсы
▶ Протоколы

Оптимизация выполнения
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Моделирование ресурсов, их жизненный цикл

Создание: нельзя выкинуть (обязательно использовать)

1 create : Params -> Resource

data Ur : Type -> Type where
MkUr : a -> Ur a

runWithCreated : Params -> (1 _ : (1 _ : Resource) -> Ur a) -> a
Потребление: нельзя использовать после

destroy : (1 _ : Resource) -> Ur Result -- или просто Unit
Нерасходующие, но зависящие? Потребить+создать

data LPair' : Type -> Type -> Type where
(#) : a -> (1 _ : b) -> LPair' a b

depend : (1 _ : Resource) -> LPair' Result Resource
Borrowing
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Использование ресурса: вырожденный пример

runWithCreated : Params -> (1 _ : (1 _ : Resource) -> Ur a) -> a
destroy : (1 _ : Resource) -> Unit
depend : (1 _ : Resource) -> LPair' Result Resource

f : Result
f = runWithCreated params \res =>

MkUr ?foo

One
Two
Three
four
1 res : Resource
------------------------------
foo : Result
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depend : (1 _ : Resource) -> LPair' Result Resource

f : Result
f = runWithCreated params \res =>

let (r # res') = depend res in
let () = destroy res' in
MkUr r

One
Two
Three
four
five
----
Successfully reloaded .../Example/Qtt/One.idr
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Использование ресурса: пример с файлами и IO
data FileHandler : FileName -> Type where ...

_
withOpenFile : LinearIO io => (fn : FileName) ->

(success : (1 _ : FileHandler fn) -> L io a) ->
(fail : L io a) -> L io a

closeFile : LinearIO io => (1 _ : FileHandler fn) -> L io Unit
readLine : LinearIO io => (1 _ : FileHandler fn) ->

L io {use=1} $ LPair' String $ FileHandler fn

f : LinearIO io => L io $ Maybe Bool
f = withOpenFile "foo" success (putStrLn "alas" *> pure Nothing)

where
success : (1 _ : FileHandler _) -> L io $ Maybe Bool
success fh = do (str # fh) <- readLine fh

closeFile fh
pure $ Just (str == "x")
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Использование ресурса: пример с файлами и IO
data FileHandler : FileName -> Type where ...
interface (Monad io, LinearBind io) => FilesAPI io where

withOpenFile : (fn : FileName) ->
(success : (1 _ : FileHandler fn) -> L io a) ->
(fail : L io a) -> L io a

closeFile : (1 _ : FileHandler fn) -> L io Unit
readLine : (1 _ : FileHandler fn) ->

L io {use=1} $ LPair' String $ FileHandler fn

f : (FilesAPI io, HasLinearIO io) => L io $ Maybe Bool
f = withOpenFile "foo" success (putStrLn "alas" *> pure Nothing)

where
success : (1 _ : FileHandler _) -> L io $ Maybe Bool
success fh = do (str # fh) <- readLine fh

closeFile fh
pure $ Just (str == "x")
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Напоминание: возможности линейных типов

Отражать в сигнатурах больше
Отражать в сигнатурах новое

▶ Ресурсы
▶ Протоколы

Оптимизация выполнения
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Протоколы в типе

Существуют session types

▶ Зависимые + линейные обеспечивают ту же выразительность
▶ Global session types vs. local session types
▶ Binary session types vs. multiparty session types
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Протоколы в типе: логинистый пример

Общение огранизовано сессиями

За сессию можно (попытаться) залогиниться один раз

При попытке залогинивания происходит проверка переданного
ключа

Успешно залогинившись, обязательно вылогиниться

Залогинившись нужно зачекиниться
▶ строго один раз
▶ в произвольный момент пока залогиненный

Залогинившись можно поменять ключ

Залогинившись можно прочитать секретную строчку
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Протоколы в типе: логинистый пример
data JournalState = NotYetCheckedIn | CheckedIn
data LoginState = Initial | LoggedIn JournalState | LoggedOut
prefix 9 @
data (@) : LoginState -> Type where ...

interface (Monad m, LinearBind m) => SimpleProtocol m where
beginSession : (1 _ : (1 _ : @ Initial) -> L m a) -> L m a
endSession : (1 _ : @ LoggedOut) -> L m Unit 
login : (1 _ : @ Initial) -> (name : String) -> (key : Key) ->

L m {use=1} $ Res Bool \case
True => @ LoggedIn NotYetCheckedIn
False => LPair' FailureReason (@ LoggedOut) 

logout : (1 _ : @ LoggedIn CheckedIn) -> L m {use=1} (@ LoggedOut) 
updateKey : (1 _ : @ LoggedIn x) -> (newKey : Key) ->

L m {use=1} $ LPair' (Maybe FailureReason) (@ LoggedIn x) 
readSecret : (1 _ : @ LoggedIn x) ->

L m {use=1} $ LPair' String (@ LoggedIn x) 
checkIn : (1 _ : @ LoggedIn NotYetCheckedIn) -> (info : String) ->

L m {use=1} (@ LoggedIn CheckedIn)
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login : (1 _ : @ Initial) -> (name : String) -> (key : Key) ->

L m {use=1} $ Res Bool \case
True => @ LoggedIn NotYetCheckedIn
False => LPair' FailureReason (@ LoggedOut)

 
logout : (1 _ : @ LoggedIn CheckedIn) -> L m {use=1} (@ LoggedOut) 
updateKey : (1 _ : @ LoggedIn x) -> (newKey : Key) ->

L m {use=1} $ LPair' (Maybe FailureReason) (@ LoggedIn x) 
readSecret : (1 _ : @ LoggedIn x) ->

L m {use=1} $ LPair' String (@ LoggedIn x) 
checkIn : (1 _ : @ LoggedIn NotYetCheckedIn) -> (info : String) ->

L m {use=1} (@ LoggedIn CheckedIn)
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

?foo
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0 m : Type -> Type
1 p : @ Initial
------------------------------
foo : L m (Either String Bool)
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f : SimpleProtocol m => L m $ Either String Bool
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0 m : Type -> Type
0 p : @ Initial
1 ans : Res Bool (\{lcase:0} => if lcase

then @ (LoggedIn NotYetCheckedIn)
else LPair' FailureReason (@ LoggedOut))

------------------------------
foo : L m (Either String Bool)
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # s) <- login p "Denis" denisKey
| (False # (reason # s)) => ?foo_bad

?foo_good
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0 m : Type -> Type
0 p : @ Initial
1 s : @ (LoggedIn NotYetCheckedIn)
------------------------------
foo_good : L m (Either String Bool)
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0 m : Type -> Type
0 p : @ Initial

reason : FailureReason
1 s : @ LoggedOut
------------------------------
foo_bad : L m (Either String Bool)

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 33 /61



Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # s) <- login p "Denis" denisKey
| (False # (reason # s)) => do

endSession s
pure $ Left $ show reason

?foo_good
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # p) <- login p "Denis" denisKey
| (False # (reason # s)) => do
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pure $ Left $ show reason

sec # p <- readSecret p
?foo
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0 m : Type -> Type
sec : String

1 p : @ (LoggedIn NotYetCheckedIn)
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foo : L m (Either String Bool)
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Протоколы в типе: логинистый пример
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # p) <- login p "Denis" denisKey
| (False # (reason # s)) => do

endSession s
pure $ Left $ show reason

sec # p <- readSecret p
p <- logout p
?foo

Error: While processing right hand side of f.
When unifying @ (LoggedIn NotYetCheckedIn) and @ (LoggedIn CheckedIn).
Mismatch between: NotYetCheckedIn and CheckedIn.

.../Example/Qtt/One.idr:437:22--437:23
|

437 | p <- logout p
| ^
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # p) <- login p "Denis" denisKey
| (False # (reason # s)) => do

endSession s
pure $ Left $ show reason

sec # p <- readSecret p
p <- checkIn p "read secret"
p <- logout p
?foo
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # p) <- login p "Denis" denisKey
| (False # (reason # s)) => do

endSession s
pure $ Left $ show reason

sec # p <- readSecret p
p <- checkIn p "read secret"
p <- logout p
pure $ Right $ sec == "foo"
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # p) <- login p "Denis" denisKey
| (False # (reason # s)) => do

endSession s
pure $ Left $ show reason

sec # p <- readSecret p
p <- checkIn p "read secret"
p <- logout p
pure $ Right $ sec == "foo"

Error: While processing right hand side of f.
There are 0 uses of linear name p.
Suggestion: linearly bounded variables must be used exactly once.

.../Example/Qtt/One.idr:438:10--438:23
|

438 | p <- logout p
| ^^^^^^^^^^^^^
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Протоколы в типе: логинистый пример
f : SimpleProtocol m => L m $ Either String Bool
f = beginSession \p => do

(True # p) <- login p "Denis" denisKey
| (False # (reason # s)) => do

endSession s
pure $ Left $ show reason

sec # p <- readSecret p
p <- checkIn p "read secret"
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Другие околопротокольные примеры

Интерфейс агента игры, где, например, в зависимости от внешних
воздействий множество возможных ответов меняется

Жизненный цикл модуля операционной системы
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Напоминание: возможности линейных типов

Отражать в сигнатурах больше
Отражать в сигнатурах новое

▶ Ресурсы
▶ Протоколы

Оптимизация выполнения
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Destructive update как оптимизация

f = runWithCreated MkParams \res =>
let (r # res) = depend res in
let () = destroy res in
MkUr r

f = beginSession \p => do
(True # p) <- login p "Denis" denisKey

| (False # (reason # s)) => do
endSession s
pure $ Left $ show reason

sec # p <- readSecret p
p <- checkIn p "read secret"
p <- logout p
endSession p
pure $ Right $ sec == "foo"

(r # y) = f x и (r # y) <- f x
могут компилироваться как обновление
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Безопасные чистые mutable структуры данных

Пример: монадический mutable массив

interface Monad m => MArray (0 ar : Nat -> Type -> Type) m where
new : (n : Nat) -> a -> m (ar n a)
read : Fin n -> ar n a -> m a
write : Fin n -> a -> ar n a -> m Unit
freeze : ar n a -> m (IArray n a) -- м.б. небезопасно --

modify : MArray ar m => (a -> a) -> Fin n -> ar n a -> m Unit
modify f i arr = do

x <- read i arr
write i (f x) arr

f : MArray ar m => Fin n -> ar n Nat -> m Nat
f i arr = do original <- read i arr

modify (+1) i arr
pure original
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Безопасные чистые mutable структуры данных
Линейный mutable массив
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freeze : (1 _ : LArray n a) -> Ur $ IArray n a
modify : (a -> a) -> Fin n -> (1 _ : LArray n a) -> LArray n a
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Когда?

В рантайме
▶ 0 — никогда

▶ 1 — ровно один раз

При компиляции — неограниченно
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Глава 4

«Эн»
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n раз

-- repN 0 f x ~ x
-- repN 1 f x ~ f x
-- repN 2 f x ~ f . f $ x
-- repN 3 f x ~ f . f . f $ x

repN : Nat -> (a -> a) -> (a -> a)
repN Z f = id
repN (S n) f = repN n (f . f)

foldr : (op : a -> b -> b) ->
(init : b) ->
Vect n a -> b

map : ([n] _ : a -> b) -> Vect n a -> Vect n b
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-- repN 3 f x ~ f . f . f $ x
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Каждый вариант подходил под сигнатуру!
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Глава 5

От и до
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Точно?

data Maybe a = Just a | Nothing
isJust : (1 _ : Maybe a) -> Bool

fromMaybe : a -> (1 _ : Maybe a) -> a
fromMaybe : ([0..1] _ : a) -> (1 _ : Maybe a) -> a
fromMaybe : (1 m : Maybe a) ->

([if isJust m then 1 else 0] _ : a) -> a

Упомянутые ранее частные случаи

[0..1] — аффинные
[1..] — relevant
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Неточные комбинации

fromMaybe : ([0..1] _ : a) -> (1 _ : Maybe a) -> a
map : ([n] _ : a -> b) -> Vect n a -> Vect n b

f : a -> Vect n (Maybe a) -> Vect n a
f d = map (fromMaybe d)

Сколько раз используется d?
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Глава 6

Полукольца
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(Полу)кольца всевластия?
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Варианты композиции синтаксис выдуманный

f : ([n] _ : A) -> B

g : ([m] _ : A) -> C

fg : (? _ : A) -> (B, C)
fg a = (f a, g a)

j : (0 _ : B) -> C

hj : (? _ : B) -> (C, C)
hj b = (h b, j b)
fj : (? _ : A) -> C
fj a = j (f a)

h : ([m] _ : B) -> C

fh : (? _ : A) -> C
fh a = h (f a)

i : (1 _ : B) -> C

hi : (? _ : B) -> (C, C)
hi b = (h b, i b)
fi : (? _ : A) -> C
fi a = i (f a)
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Полукольца

Сложение
▶ Коммутативно: 𝑎 + 𝑏 = 𝑏 + 𝑎
▶ Ассоциативно: (𝑎 + 𝑏) + 𝑐 = 𝑎 + (𝑏 + 𝑐)
▶ Существует ноль: 𝑎 + 0 = 0 + 𝑎 = 𝑎

Умножение
▶ Ассоциативно: (𝑎 ∗ 𝑏) ∗ 𝑐 = 𝑎 ∗ (𝑏 ∗ 𝑐)
▶ Ноль от сложения даёт ноль: 𝑎 ∗ 0 = 0 ∗ 𝑎 = 0
▶ Коммутативность не требуется

Дистрибутивность сложения и умножения
▶ Левая 𝑎 ∗ (𝑏 + 𝑐) = 𝑎 ∗ 𝑏 + 𝑎 ∗ 𝑐
▶ Правая (𝑎 + 𝑏) ∗ 𝑐 = 𝑎 ∗ 𝑐 + 𝑏 ∗ 𝑐

Предпорядок
▶ Рефлективность: 𝑎 ≺ 𝑎
▶ Транзитивность: 𝑎 ≺ 𝑏 ∧ 𝑏 ≺ 𝑐 ⇒ 𝑎 ≺ 𝑐
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Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡
Натуральные числа, ⩽
Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}

Натуральные числа, ≡
Натуральные числа, ⩽
Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡

Натуральные числа, ⩽
Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡
Натуральные числа, ⩽

Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡
Натуральные числа, ⩽
Натуральные числа с 𝜔

Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡
Натуральные числа, ⩽
Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡
Натуральные числа, ⩽
Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡
Натуральные числа, ⩽
Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольца с предпорядком

{0, 1, 𝜔}
Натуральные числа, ≡
Натуральные числа, ⩽
Натуральные числа с 𝜔
Отрезок натуральных чисел

Пара полуколец с предпорядком

Приватность

…

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 49 /61



Полукольцо приватности

record User where
constructor MkUser
[Public] nick : String
[Private] email : String

data Pu : Type -> Type where
MkPu : ([Public] _ : a) -> Pu a

data Pr : Type -> Type where
MkPr : ([Private] _ : a) -> Pr a

f : Fin n -> Vect n User -> Pu String
f i v = let MkUser {email=str, ...} = index i v

in str
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Глава 7

Впихнуть невпихуемое
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При таких свиньях как-то сам становишься…

f : Nat -> A
g : (1 _ : A) -> B -- много не просит

let x = f 5 in ?foo
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При таких свиньях как-то сам становишься…

f : Nat -> A
g : (1 _ : A) -> B -- много не просит
let x = f 5 in g x -- можем дать больше, чем просят
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При таких свиньях как-то сам становишься…

map : (a -> b) -> List a -> List b -- ничего не просит от аргумента

inc : (1 _ : Nat) -> Nat -- функция кое-что обещает
mi : List Nat -> List Nat
mi = map inc -- дали больше, чем просят

interface Con w where
constructor MkCon
con : Nat -> w -- con : Con w => Nat -> w

mkCon : (a -> b) -> Con (a -> b) -- instance первого порядка
mkCon f = MkCon {con = \_ => f}
bang : (a -> b) -> (1 _ : a) -> b
bang f = let cc = mkCon f in ?foo
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При таких свиньях как-то сам становишься…

map : (a -> b) -> List a -> List b -- ничего не просит от аргумента
inc : (1 _ : Nat) -> Nat -- функция кое-что обещает
mi : List Nat -> List Nat
mi = map inc -- дали больше, чем просят

interface Con w where
constructor MkCon
con : Nat -> w -- con : Con w => Nat -> w

mkCon : (a -> b) -> Con (a -> b) -- instance первого порядка
mkCon f = MkCon {con = \_ => f}
bang : (a -> b) -> (1 _ : a) -> b
bang f = let cc = mkCon f in con 5 -- утекло :-(
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Какая сложна

Не только функции контравариантны по своим аргументам

Полиморфизм
▶ Рекурсивные структуры данных?

Дерайвинг

…
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Глава 8

Спецификации спецификаций
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QTT ⟹ GrTT

Разрабатывается в Granule Project

Некоторые отличия
▶ Quantity привязана к типу

new : (n : Nat) -> a -> [1] LArray n a
read : Fin n -> [1] LArray n a -> (a, [1] LArray n a)
write : Fin n -> a -> [1] LArray n a -> [1] LArray n a
freeze : [1] LArray n a -> [] Vect n a

▶ Quantity’ей две: одна рантаймовая, другая спецификационная

id : {a : [0, 2] Type} -> [k, 0] a -> [k, 0] a
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Глава 9

Заключение

Денис Буздало́в * * Циферьки в типах *или* Quantitative type theory 03.02.2021 57 /61



Блеск
Более точные намерения, известные компилятору

▶ проверка при компиляции
▶ более эффективное исполнение

Исправление фундаментального косяка с parametricity

Новые возможности: например, протоколы в типе

Возможности более безопасных интерфейсов

Много нерешённых проблем

Много вариативности: ещё непонятно, как хорошо, а как нет

Вопросы удобства

Поэтому, область развивается с безумной скоростью прямо сейчас
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Сладкий мир циферек в типах

Бывают и другие циферьки (и не только циферьки), например

▶ номер вселенной в теории зависимых типов
▶ гомотопический уровень в гомотопической теории типов
▶ мера ленивости вычисления
▶ мера сложности вычисления значения этого типа
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